WikiDB/Legacy versions

From TestWiki
< WikiDB
Revision as of 20:07, 30 March 2019 by HappyDog (Talk | contribs) (MediaWiki < 1.6: Tweak wording.)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

This page details which versions of WikiDB should be used in situations where you want to run the extension on a version of MediaWiki that is no longer supported.

MediaWiki versions[edit]

MediaWiki 1.16 and above[edit]

Use the latest version of WikiDB.

MediaWiki 1.7 to 1.15[edit]

The last version of WikiDB to support these versions of MediaWiki was v4, r1376.

This version supported MediaWiki 1.7 to 1.15, but with a limited feature-set. Some features of WikiDB, most notably the ability to use the WikiDB tags within templates, are only available if you are using MediaWiki 1.16 or above. Earlier versions are still supported, back to MediaWiki 1.7, but some features cannot be supported on these earlier versions due to limitations in MediaWiki.

MediaWiki 1.6[edit]

The last version of WikiDB to support MediaWiki 1.6 was v3, r816.

MediaWiki < 1.6[edit]

No specific legacy releases are available for versions of MediaWiki prior to 1.6. You can try using the latest 1.6 release, which may work on older MediaWiki versions (though with reduced functionality), but this is untested.

Support for legacy versions[edit]

I am happy to answer questions relating to any version of WikiDB, including legacy versions.

Bugs in older versions will not be fixed unless they are show-stoppers that prevent the extension from being usable and for which there is no workaround. In this situation an additional legacy release may be considered, but I will evaluate this on a case-by-case basis. Bugs which are not show-stoppers should not be reported unless also an issue in the latest release, in which case they will be fixed in the latest release, only.

Any bugs that meet the criteria listed above, should be reported in the usual way. When reporting a bug against a legacy release then please make sure this is made clear, and include full details of the versions of WikiDB, MediaWiki and PHP that you are using.