Difference between revisions of "Talk:WikiDB/Repeat tag syntax"

From TestWiki
Jump to: navigation, search
(Reply)
 
Line 5: Line 5:
 
</pre>
 
</pre>
 
But when I try to add internal wiki links: <tt><nowiki><repeat table="Locations" criteria="Code={{{1}}}">[[Location/{{{Code}}}|{{{Code}}}]]</repeat></nowiki></tt>, it shows the brackets instead of making a link. Single brackets work for external links, but double brackets don't work for internal links.  Suggestions? [[Special:Contributions/72.1.73.217|72.1.73.217]] 14:57, 29 December 2017 (GMT)
 
But when I try to add internal wiki links: <tt><nowiki><repeat table="Locations" criteria="Code={{{1}}}">[[Location/{{{Code}}}|{{{Code}}}]]</repeat></nowiki></tt>, it shows the brackets instead of making a link. Single brackets work for external links, but double brackets don't work for internal links.  Suggestions? [[Special:Contributions/72.1.73.217|72.1.73.217]] 14:57, 29 December 2017 (GMT)
 +
 +
: I've created a simplified test case, using data from the [[Table:Companies|Companies table]] on this wiki, which seems to work correctly:
 +
: '''Code:'''
 +
<pre>
 +
<repeat table="Companies">
 +
:* [[Foo/{{{name}}}|{{{name}}}]]
 +
</repeat>
 +
</pre>
 +
: '''Result:'''
 +
<repeat table="Companies">
 +
:* [[Foo/{{{name}}}|{{{name}}}]]
 +
</repeat>
 +
: Can you please confirm that you are using the latest version of WikiDB and that you are using the correct field names (note that field names are case-sensitive)?
 +
: If so, please let me know which version of MediaWiki you are experiencing this on.  If possible, it would be useful if I could access the example directly on your wiki, so I can investigate further.
 +
: --[[User:HappyDog|HappyDog]] ([[User talk:HappyDog|talk]]) 21:00, 29 December 2017 (GMT)

Latest revision as of 21:00, 29 December 2017

See Talk:WikiDB/Repeat tag syntax/Archive for old development discussion.

I have a template that uses <repeat> and works fine:
<repeat table="Locations" criteria="Code={{{1}}}">{{{Code}}} ({{{Nickname}}}) {{#if:{{{Address|}}}|[https://www.google.com/maps/search/{{urlencode:{{{Address}}}}}?hl=en&source=opensearch {{{Address}}}]|''No Address''}}</repeat>

But when I try to add internal wiki links: <repeat table="Locations" criteria="Code={{{1}}}">[[Location/{{{Code}}}|{{{Code}}}]]</repeat>, it shows the brackets instead of making a link. Single brackets work for external links, but double brackets don't work for internal links. Suggestions? 72.1.73.217 14:57, 29 December 2017 (GMT)

I've created a simplified test case, using data from the Companies table on this wiki, which seems to work correctly:
Code:
<repeat table="Companies">
:* [[Foo/{{{name}}}|{{{name}}}]]
</repeat>
Result:
Can you please confirm that you are using the latest version of WikiDB and that you are using the correct field names (note that field names are case-sensitive)?
If so, please let me know which version of MediaWiki you are experiencing this on. If possible, it would be useful if I could access the example directly on your wiki, so I can investigate further.
--HappyDog (talk) 21:00, 29 December 2017 (GMT)